Default Web Site Browse method in IIS 6.0 renders wrong pageRSS

4 replies

Last post Sep 06, 2006 03:51 PM by RobZappa

  • Default Web Site Browse method in IIS 6.0 renders wrong page

    Sep 06, 2006 09:28 AM|RobZappa|LINK

    I have a Windows 2003 Server running IIS 6.0., SQL Server 2005 and SharePoint Services. I have placed a simple ASP.NET application developed in Visual Studio 2003 into the Default Web Site (InetPub\wwwroot) and have set the StartPage.aspx as the default document (at the top of the default content pages list) on the Documents tab of the web site properties dialog. I am able to render the page appropriately from my desktop browser but when I right click on the Default Web Site and Select "Browse" from within IIS Manager, I get the "Under Construction" page (iisstart.htm) with the message:
    "The site you are trying to view does not currently have a default page."

    I have moved iisstart.htm to the bottom of the list, re-started IIS and it still appears.  From a users standpoint, all is working fine but I cannot for the life of me determine why the browse method from within IIS renders this page.
    Any insight would be appreciated. I'm also curious if the behavior of the Default Web Site is any different than the other created sites.
    Thanks,
    Rob

  • Re: Default Web Site Browse method in IIS 6.0 renders wrong page

    Sep 06, 2006 11:42 AM|tomkmvp|LINK

    Does the default site have WSS active?
    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Default Web Site Browse method in IIS 6.0 renders wrong page

    Sep 06, 2006 02:20 PM|RobZappa|LINK

    Share Point Central Administration is a separate website (using the same IP address) on a different port (17012). I see no reference to Share Point in the Default Web Site dialogs. Is this what you are asking?
  • Re: Default Web Site Browse method in IIS 6.0 renders wrong page

    Sep 06, 2006 03:18 PM|tomkmvp|LINK

    Sort of.  When you said "Sharepoint Services" I thought you meant Windows SharePoint Services, as opposed to the FrontPage Server Extensions.
    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Default Web Site Browse method in IIS 6.0 renders wrong page

    Sep 06, 2006 03:51 PM|RobZappa|LINK

    I do have SharePoint Services, not Front Page Extensions