We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

404.4 error trying to get php file to run???RSS

2 replies

Last post Jun 18, 2006 06:13 PM by jtzako

  • 404.4 error trying to get php file to run???

    Jun 17, 2006 12:07 PM|jtzako|LINK

    I formatted and reinstalled Vista due to issues so Im starting over with IIS 7 and PHP...

    Followed the instructions in http://forums.iis.net/thread/1314574.aspx to get PHP enabled in my IIS.

    The problem is that it doesnt seem to be working..  I get the error page below if I try to access a php file that is within my wwwroot folder.  Any ideas why this is?

    I also noticed I do not have an IUSR_<hostename> on this computer but I did before the format.  Is this required for IIS7?  If not, what user do I give permissions to "write" to the coppermine folder?

    Server Error in 'JTStuff' Application.


    HTTP Error 404.4 - Not Found

    Description: The resource you are looking for does not have a module or handler associated with it. It cannot be handled and served.

    Error Code: 0x00000000

    Notification: ExecuteRequestHandler

    Module: IIS Web Core

    Requested URL: http://home2:80/coppermine/install.php

    Physical Path: C:\inetpub\wwwroot\coppermine\install.php

    Logon User: Anonymous

    Logon Method: Anonymous

    Handler: PHP

    Causes:

    • The file extension for the requested URL does not have a module or handler configured to execute the request on the IIS server.

    Solution:

    • If you determine that the file extension being denied is required by the Web server, add the appropriate handler for the file extension by following these steps:
      1. From the IISWeb Management tool, open a connection to the web site.
      2. Double click the Handlers Management feature.
      3. Click New Server Module Handler in the Tasks pane.
      4. Complete the Wizard pages to add the handler information, and then click Finish to add the handler to the list.
      5. Go back to the list of management features and double-click the ISAPI and CGI Restrictions Management feature.
      6. Click New Restriction in the Tasks pane.
      7. Complete information for the new extension, check Allow extension path to execute, and then click OK.
    • Set up a new Failed Request Trace rule for this HTTP status code.
      1. Use the IIS Web Management tool to open a connection to the Web server where the problem is occurring.
      2. In the tree view, navigate to the Web site, and then click to select it.
      3. In the Tasks pane, click Failed Request Tracing.
      4. Check Enable Logging for this Site, specify a logging folder or use the default log folder, and then click OK
      5. Open the Failed Request Tracing Rules feature and click New Rule in the Tasks pane.
      6. Specify the content type to monitor and then click Next.
      7. Check the Status Codes checkbox, type 404.3 in the Edit box, and then click Next.
      8. In the Providers area, make sure that the WWW Server is checked and highlighted, and that in Provider Properties, the Verbosity level is set to Verbose.
      9. Click FinishRequest the page that generated the 404.3 error and then look at the tracing file that was created for the request. This file is located in the logging folder you specified in Step 4.

    More Information... This error means that the IIS server does not recognize the file extension of the requested resource. A module handler is not configured on the Web server for this extension. If the file extension being denied is required by the Web server, add the appropriate handler for the file extension.

    Microsoft Knowledge Base Articles:


    Server Version Information: Internet Information Services 7.0.

  • Re: 404.4 error trying to get php file to run???

    Jun 18, 2006 02:09 PM|mvolo|LINK

    This error typically means that you don't have a handler mapping registered in your application to process .PHP requests.  Can you make sure that you have added the handler mapping as Bill indicates in the thread you mention?

    You can confirm that by starting "inetmgr", finding your application (Default Web Site for wwwroot) in the left side tree view, and then openining the "handler mappings" configuration to make sure that you have a mapping for .PHP.

    Thanks,

    Mike V.
    CTO at LeanSentry, Former IIS PM

    Expert guides:
    1. Restart IIS correctly
    2. Expert guide to IIS logs
    3. Tune IIS thread pool
  • Re: 404.4 error trying to get php file to run???

    Jun 18, 2006 06:13 PM|jtzako|LINK

    Thanks!  I had it in there but I had *.php (as another site had suggested) and it didnt work intil I made it just .php   ...