View Complete Thread
  • $metadata 404 (Not Found) when hosting SAPUI5 app that connects to WCF data service

    Oct 21, 2016 04:50 PM|Hitman47|LINK

    I have been developing SAPUI5 app that connects to WCF data service written in C# and there was no problem in the development process till i started to host the SAPUI5 app on my local IIS i started to get the following error in chrome developer tools $metadata 404 (Not Found) whenever i tried to connect to the service  Error

    While in eclipse the code runs with no error No error

    and hosted it on my local IIS and things were more than perfect then i developed a client app with SAPUI5 framework and again it was so smooth with zero errors until i hosted my client app on the local IIS i started to get the following error $metadata 404 (Not Found)

    Server Error in '/' Application.


    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

    Requested URL: /proxy/http/mikmo.mylocalhost.com/MIKMOWCFDataService.svc/$metadata


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1073.0

    While developing i didnt get that error and i was developing the client app with Eclipse that uses Apache tomcat to run the SAPUI5 app

    Any help would be appreciated 

    Thanks in advance