View Complete Thread
  • Re: Error 500 if Server-Side Processing Exceeds 5 Seconds - PHP 5.5.10, IIS 7.0, FastCGI

    Oct 28, 2014 05:18 AM|Pengzhen Song - MSFT|LINK

    Hi,

    I find the default value for connection to mssql is 5s. So try setting a appropriate value for the connection timeout in php.ini

    mssql.connect_timeout = xx

    try setting activityTimout and requestTimeout attribute in applicationhost.config or via iis manger UI( under the server level->FastCGI Settings/Edit.)

    <application fullPath="C:\Program Files (x86)\PHP\v5.5\php-cgi.exe" monitorChangesTo="php.ini" activityTimeout="601" requestTimeout="601" instanceMaxRequests="10000">
                    xxxxxxxxxx
    </application>

    In addition, please refer to the similar discussion:

    http://forums.iis.net/t/1150670.aspx?The+FastCGI+process+exceeded+configured+activity+timeout

    We are trying to better understand customer views on social support experience. Click HERE to participate the survey.
    Thanks!