View Complete Thread
  • Re: Getting WScript.Shell to Run on IIS Server

    Dec 04, 2013 10:48 AM|billbell52|LINK

    Problem Solved!!!  Solution was amazingly simple.

    1. An Office product can only run under a user account.  It needs to load user settings.

    2.  Solution was to have the app pool run under a custom account.

      Right click the correct app pool.  Click advanced settings.  Under Process Model click on Identity and add a custom user that can run Word.

    I know some may cringe at this solution.  Please note this is for a small intranet app.  So far tests have seemed reliable.  MS recommends using XML and their Open XML SDK.  This approach produces docs that are 10X as large.  Completely unacceptable.

    Wscript php