We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

View Complete Thread
  • IIS Incorrect on Invalid Markup

    Dec 21, 2009 10:23 AM|dbaechtel|LINK

    On my website, the page starts out with the following:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml">

    <head>

          <title>School-DashBoard Home</title><meta name="Keywords" content="School, Dashboard, School Dashboard, School-DashBoard" /><meta name="Description" content="This is the School Dashboard site." />

          <link href="http://cdn1.officelivecontent.com/2.02.2407.0/WebHosting/_layouts/1033/wh/stylesV2/masterroot.css" mce_href="http://cdn1.officelivecontent.com/2.02.2407.0/WebHosting/_layouts/1033/wh/stylesV2/masterroot.css" type="text/css" rel="stylesheet" />

           <link href="http://cdn1.officelivecontent.com/2.02.2407.0/WebHosting/_layouts/1033/wh/stylesV2/tables.css" mce_href="http://cdn1.officelivecontent.com/2.02.2407.0/WebHosting/_layouts/1033/wh/stylesV2/tables.css" type="text/css" rel="stylesheet" />

          <link type="text/css" rel="stylesheet" href="/theme.css" mce_href="/theme.css" />

          <style type="text/css"> </style>

    </head>

    <body> ...

    SEO Toolkit reports: "The page contains invalid markup.
    The Tag 'style' was not closed correctly, the Tag 'head' was closed instead.

    It looks like to me that the style tag is open and closed correctly, and so is the head tag.

    So why does SEO Toolkit report this a invalid markup ?

    Are the remainder of the SEO Toolkit detections just as inaccurate?

    iis seo toolkit Invalid Markup