View Complete Thread
  • Re: Problem with PHP install from Web Platform

    Nov 22, 2009 04:29 PM|SteveRicketts|LINK

    Ok, I uninstalled PHP then FastCGI... however, it said FastCGI (x86) not IIS FastCGI in uninstall programs.  So, I went to WPI and selected PHP.  It did identify the IIS FastCGI dependancy.  Accepted the agreement and it downloaded and installed.

     However, still no .php mapping in IIS.  Pages can't be found.

    First script still works

    Second script, still no output

    fcgiconnfig.js does exist

    fcgiext.ini has the types I entered... didn't remove that before reinstall

    php-cgi.exe -v gives similar output (shows 5.2.11 not 5.3)

    php-cgi.exe test.php gives proper output "this is my first php program"

    Accessing the test.php from the web browser gives 404 error... and like I said, there are no .php mappings in the default web (port 80).

    To answer your last question, this is a 32 bit machine and I removed the program files\php directory.

    Should I try to configure the .php mapping manually?

     sr

     

    Life more interesting viewed upside down.