We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

View Complete Thread
  • Re: ASP db connection problem in IIS7

    Nov 14, 2009 10:33 AM|u1anderson|LINK

    Same problem here, getting:

    ADODB.Connection error '800a0e7a'

    Provider cannot be found. It may not be properly installed.

    Running Windows 7 Ultimate 64-bit IIS 7.5 

     

    Setting Enable 32-Bit Applications=True  in the Advanced Settings on the Application Pool solved it for me.

     

     

    - In Internet Information Services (IIS) Manager, select the IIS Server 

    - Actions -> View Application Pools

    - Select the application pool for your web site

    - Under Edit Application Pool, click Advanced Settings...

    - Set Enable 32-bit Applications to True (default is False)

     

    Works now!