We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

View Complete Thread
  • ASP.NET Configuration (HTTP Error 404.3 - Not Found)

    Sep 21, 2006 12:41 PM|jbristowe|LINK

    I am unable to serve up an ASP.NET page from IIS 7.0 on Windows Vista RC 1 (Ultimate Edition). Requests for an ASP.NET page (i.e. default.aspx) return the following message:

    HTTP Error 404.3 - Not Found

    Description: The page you are requesting cannot be served because of the Multipurpose Internet Mail Extensions (MIME) map policy that is configured on the Web server. The page you requested has a file name extension that is not recognized, and is not allowed.

    Error Code: 0x80070032

    ASP.NET is installed and enabled on IIS 7.0 (via the "Windows Features" applet in the Control Panel). When I examine the handler mappings for the machine (itself), the following entries are listed:

    PageHandlerFactory-Integrated | *.aspx | Enabled | Unspecified | System.Web.UI.SimpleHandlerFactory | Local

    PageHandlerFactory-ISAPI-1.1 | *.aspx | Enabled | Unspecified | IsapiModule | Local

    PageHandlerFactory-ISAPI-2.0 | *.aspx | Enabled | Unspecified | IsapiModule | Local

    Note: These entries (above) are not listed for the default Web site or any of its applications. (I can only assume that they are inherited.)

    When I explicitly add a handler for the path, "*.aspx" to one of my applications, the error no longer appears. However, the ASP.NET does not appear to execute. (The content served back from IIS 7.0 is empty.)

    I would appreciate any advice to help resolve this issue.

    "ASP.NET" Configuration "IIS 7.0"