We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

IIS10: The Module DLL xxx failed to load. The data is the error.RSS

1 reply

Last post Apr 20, 2021 06:08 PM by lextm

‹ Previous Thread|Next Thread ›
  • IIS10: The Module DLL xxx failed to load. The data is the error.

    Apr 20, 2021 07:02 AM|filippo.zhang|LINK

    We have a COM+ dll module  that loads while the web application is launching. It works well on Windows Server 2012 R2/IIS 8.5.  However, after we upgrade to Windows Server 2019/IIS 10, we got the following error

    The Module DLL xxx.dll failed to load.  The data is the error.

    We see code like "7E000000".  After searching internet, there is no working solution found.  Not sure if there is a way to identify why the dll fails to load.

    Much appreciated for any help!

  • Re: IIS10: The Module DLL xxx failed to load. The data is the error.

    Apr 20, 2021 06:08 PM|lextm|LINK

    If it is a vendor product, contact its vendor so the original developers can troubleshoot.

    If it is developed by your own guys, debug further with the source code.

    It is rather common to see such incompatibilities, as each versions of Windows/IIS introduce minor changes under the hood.

    Lex Li
    Want to have a chat on the issues you meet? Find me at https://booktime.xyz/p/lextm
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
‹ Previous Thread|Next Thread ›