IIS Windows 10 Core Web API getting ERR_HTTP2_PROTOCOL_ERRORRSS

2 replies

Last post Feb 12, 2021 01:18 PM by chopswil11

  • IIS Windows 10 Core Web API getting ERR_HTTP2_PROTOCOL_ERROR

    Feb 11, 2021 01:31 PM|chopswil11|LINK

    I have a core 3.1 web api that work via Visual Studio and now I've published to my local windows 10 IIS.

    However when i browse to the site via IIS(Manage Website -> Browser) the chrome browser opens with the message below about ERR_HTTP2_PROTOCOL_ERROR.

    in the application pool the ".Net CLR Version" is set to "No Managed Code"

    w w w.pathfinderservicecore.com in my host file for local host.

    and i have a self sign cert in IIS for this site

    What am i doing wrong?

    The Message

    This site can’t be reached The webpage at https://www.pathfinderservicecore.com/ might be temporarily down or it may have moved permanently to a new web address.
    ERR_HTTP2_PROTOCOL_ERROR

  • Re: IIS Windows 10 Core Web API getting ERR_HTTP2_PROTOCOL_ERROR

    Feb 12, 2021 01:58 AM|samwu|LINK

    Hi chopswill,

    chopswil11

    This site can’t be reached The webpage at https://www.pathfinderservicecore.com/ might be temporarily down or it may have moved permanently to a new web address.
    ERR_HTTP2_PROTOCOL_ERROR

    There are many reasons for this error, you can try the following methods to solve the problem:

    1. Please check if there is free disk space on the web server.

    2. Clear the browser's cache and restart the browser.

    2. Update the Chrome browser to the latest version.

    4. Make sure you enable https=- true in package.json file.

    Best regards,

    Sam

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: IIS Windows 10 Core Web API getting ERR_HTTP2_PROTOCOL_ERROR

    Feb 12, 2021 01:18 PM|chopswil11|LINK

    Sam,

    Adding  "https_port": 443 to appsettings.json did the trick!!

    thank you,

    mike