405 - HTTP verb used to access this page is not allowed.RSS

1 reply

Last post Mar 23, 2020 03:10 AM by Jalpa Panchal

  • 405 - HTTP verb used to access this page is not allowed.

    Mar 20, 2020 08:44 PM|hokn|LINK

    I configured an IIS website whose default document is "index.html" which basically redirects user to a specific page. When I hit this website, I am being asked to enter my credentials, and then get a "confirm resubmission" alert and then end up with http 405 error. This happens only in Chrome. In IE and Edge, I do not get 405 error.

    -I tried looking into IIS logs but not much is provided.

    -when I change the default document to default.aspx and do the redirect, it works in chrome but in IE and Edge, I get prompted twice for credentials.

    -if i change the default document to index.html, i get 405 in chrome but works fine in IE and edge.

    Any suggestions?

  • Re: 405 - HTTP verb used to access this page is not allowed.

    Mar 23, 2020 03:10 AM|Jalpa Panchal|LINK

    Hi,

    Could you please share what kind of application you are using? is it just Html or .net application? are you using any method like post, put or something else in your page? did you enable the static content feature of iis? which authentication did you enable at your site level in iis? 

    You could try below steps to resolve the issue:

    disable the WebDAV iis feature:

    the reason behind the  ‘Confirm Form Resubmission’ may flash on your screen when you reload your browser could be one of the following:

    Reason 1 – The page that you refreshed did genuinely consist of a form that may or may not require resubmission.

    Reason 2 – You tried to switch web pages while you were halfway through filling a form.

    Reason 3 – Your internet connection is faulty or improper.

    to Fix the Confirm Form Resubmission Error:

    Method -1: Replacing the POST Method

    Just remove POST from the URL & use GET at its place. For example:

    //Remove POST
    <form action=”index.php?load=SEARCH” method=”post”> 
    //Use GET
    <form action=”index.php?load=SEARCH” method=”get”>

    Method -2: Using Google Chrome Properties


    Right-click on the Shortcut icon of Google Chrome and select the Properties option.

    A dialog box will pop up & you’ll be able to a field named as Target.

    Google Chrome Target Field

    Now, just add this text “–disable-prompt-on-repost” (Without quotes) to the end of the target.


    For me, the target is:

    “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe.”

    Simply, change the above target URL with the below one:


    “C:\Program Files (x86)\Google\Chrome\Application\chrome.exe”-disable-prompt-on-repost

    After doing so, if Google Chrome is already open, then close it down and re-open using the same shortcut.

    Now, check if the same kind of dialog pops up or not on refreshing the web page.

    Method -4: Clear Google Chrome Browsing Data

    Try to clear out the browsing data from time to time. While doing so, you must take care that you select all the options viz. Browsing history, cookies, passwords, cached data, media licenses, etc. After clearing browsing data, try using the browser again and see if the error has resolved or not.

    Regards,

    Jalpa

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.