site works in c:\testing but not in c:\users\uname\gDrive\testingRSS

2 replies

Last post Dec 30, 2019 01:26 AM by Jalpa Panchal

  • site works in c:\testing but not in c:\users\uname\gDrive\testing

    Dec 27, 2019 05:01 PM|Mel_3|LINK

    Running iis 6.1 on Win7 Pro on my PC for simple php testing & dev work

    Note: CNAME-I7 = computer name
    Note: User-01 = user name

    index.php has the following simple code...

    <? php echo 'Current PHP version: ' . phpversion(); ?>

    -1- for site: testing.com at c:\testing\

    clicking "Browse Website" in IIS works & brings up the site on my local PC

    -2 - for site: gDrivePHPtest.com at C:\Users\user-01\gDrive\gDrivePHPtest\
    clicking "Browse Website" in IIS does not work & takes me to the web & "no site found"

    FYI: The gDrive folder is sync'd to my google drive and is also shared on my peer to peer home network to another PC in the house... so I don't think "sharing is an issue"

    I've worked on this for hours and hours...  and would really appreciate any help in solving the problem

    More info if needed:

    On the IIS manager for either of the two sites... if I click Basic Settings > Test Settings

    I get the following results

    Test: Authentication

    Setting: Pass-through authentication (path to site files)

    Test: Authorization

    Settings: Cannot verify access to path

    And even more info... if needed:

    ==============================================
    for site: testing.com

    Edit Permissions > Sharing Tab
    - Not Shared

    - Group or user names:
    -- Authenticated Users
    -- SYSTEM
    -- Administrators (CNAME-I7\administrators)
    -- Users (CNAME-I7\Users)

    ===============================================
    for site: gDrivePHPtest.com

    Edit Permissions > Sharing Tab
    - Shared
    - Network Path
    \\CNAME-I7\Users\User-01\gdrive\dDrivePHPtest

    - Click Share Button
    -- Shared with
    ---- Everyone Read/Write
    ---- User-01 Owner

    Edit Permissions > Security Tab

    - Group or user names:
    -- Everyone
    -- SYSTEM
    -- User-01 (CNAME-I7\User-01)
    -- Administrators (CNAME-I7\administrators)
    -- Users (CNAME-I7\Users)

  • Re: site works in c:\testing but not in c:\users\uname\gDrive\testing

    Dec 28, 2019 12:01 AM|Mel_3|LINK

    Solved. Forgot to modify host file in c:\windows\system32\drivers\etc

    and from IIS manager... with the site selected... click on Directory Browsing and enable

  • Re: site works in c:\testing but not in c:\users\uname\gDrive\testing

    Dec 30, 2019 01:26 AM|Jalpa Panchal|LINK

    Hi

    If your issue is solved then I request you to mark the helpful suggestion as an answer. This will help other people who face the same issue.

    If your issue still exists then try to refer the solution given by the community members.

    If then also you have any further questions then let us know about it.

    We will try to provide further suggestions to solve the issue.

    Thanks for your understanding.

    Regards

    Jalpa.

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.