We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Unable to browse certsrv RSS

3 replies

Last post Jun 18, 2021 09:54 AM by vicemuca

‹ Previous Thread|Next Thread ›
  • Unable to browse certsrv

    Dec 06, 2019 05:39 PM|Criagnin532|LINK

    Added the roles for certsrv but cant seem to browse

    This was a WSUS server previously.

    Wondering if reinstalling IIS and WAS would resolve without creating ay other issues.  Currently this IIS is hosting nothing else

     

    Server Error in Application "application name"

    HTTP Error 500.19 – Internal Server Error

    HRESULT: 0x8007007e

    Description of HResult
    The requested page cannot be accessed because the related configuration data for the page is invalid.
    This problem occurs because the ApplicationHost.config file or the Web.config file references a module or a DLL that is invalid or that does not exist. In the ApplicationHost.config file or in the Web.config file, locate the module reference or the DLL reference that is invalid, and then fix the reference. To determine which module reference is incorrect, enable Failed Request Tracing, and then reproduce the problem.  

  • Re: Unable to browse certsrv

    Dec 06, 2019 10:31 PM|lextm|LINK

    That error page already tells you what to do next, but I guess you just hit a well known issue of WSUS,

    https://blog.lextudio.com/iis-7-and-wsus-on-windows-server-x64-1b59da5ac7ee

    Lex Li
    Want to have a chat on the issues you meet? Book an appointment at https://buy.stripe.com/cN24ia0yi7sAdIA7sv
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Unable to browse certsrv

    Dec 09, 2019 06:24 AM|Jalpa Panchal|LINK

    Hi,

    To resolve this problem: In the ApplicationHost.config file or in the Web.config file, locate the module reference or the DLL reference that is invalid and then fix the reference.

    To determine which module reference is incorrect, enable Failed Request Tracing, and then reproduce the problem.

    For above specific error (mentioned in this example), the DynamicCompressionModule module is causing trouble. This is because of the XPress compression scheme module (suscomp.dll) which gets installed with WSUS. Since Compression schemes are defined globally and try to load in every application Pool, it will result in this error when 64bit version of suscomp.dll attempts to load in an application pool which is running in 32bit mode.

    1.Navigate to %WINDIR%\system32\inetsrv\config\
    2. Create a backup copy of the file applicationhost.config and save it to a different location.
    3. Open the applicationhost.config in Notepad.
    4. Search for the following entry:
    <scheme name="xpress" doStaticCompression="false" doDynamicCompression="true" dll="C:\Windows\system32\inetsrv\suscomp.dll" staticCompressionLevel="10" dynamicCompressionLevel="0" />

    5. Remove or disable the XPress compression schema from the configuration using the command below:
    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']
    6. Verify if the compression schema has been removed form the applicationhost.config.
    7. Save the applicationhost.config and restart IIS services.

    you could refer this below article for more detail:

    https://blogs.msdn.microsoft.com/webtopics/2010/03/08/troubleshooting-http-500-19-errors-in-iis-7/

    http://interactivewebs.com/index.php/general-tips/crtsrv-http-error-500-19-internal-server-error-64-bit-windows-2008/

    Regards,

    Jalpa

    .NET forums are moving to a new home on Microsoft Q&A, we encourage you to go to Microsoft Q&A for .NET for posting new questions and get involved today.
  • Re: Unable to browse certsrv

    Jun 18, 2021 09:54 AM|vicemuca|LINK

    Worked for me like a charm. Thanks!

‹ Previous Thread|Next Thread ›