Application Pool Takes too long to restartRSS

1 reply

Last post Jul 30, 2019 01:52 AM by Able

  • Application Pool Takes too long to restart

    Jul 29, 2019 06:28 AM|umair.ahmed711|LINK

    I have been searching for this issue but in vain. 

    We have a server 2012 R2 with IIS v8.5.9600. We have multiple serviecs configured in default AppPool as well as other websites parallel to default. When we deploy a library to dot net library, we need to restart the services for changes to take effect. I have dig down the websites for sloweset one and its the default Website. It takes atleast 130 to 175 seconds for users to be able to login to the application. 

    The code runs smooth on another server but this server lags too much. 

    Any help would be appreciated .

  • Re: Application Pool Takes too long to restart

    Jul 30, 2019 01:52 AM|Able|LINK

    Hi umair.ahmed711,

    According to your description,I think that the best way is to use Failed quest tracing  to see the which module would cost much time in the request.Then you could use debugdialog to catch and analyze the performance dump.

    Here is the link ,I hope it could help you.

    https://docs.microsoft.com/en-us/iis/troubleshoot/using-failed-request-tracing/troubleshooting-failed-requests-using-tracing-in-iis

    https://support.microsoft.com/en-us/help/919792/how-to-use-the-debug-diagnostics-tool-to-troubleshoot-a-process-that-h

    Best Regards

    Able

    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.