Can't access website with external IP IIS 8.0RSS

2 replies

Last post Jul 04, 2019 03:31 AM by DNK85

  • Can't access website with external IP IIS 8.0

    Jul 04, 2019 03:14 AM|DNK85|LINK

    Dear All,

    I am facing the issue when publishing my portal to Internet. I can access my portal successful with my local IP, but after NAT this portal to internet, I can't login to this portal with public IP. Let me show the diagram and what what was I configured as below:

    Assuming that my public IP is 1.1.1.1:

    +  Diagram:      Internet ------> (1.1.1.1:82) Firewall (192.168.1.1) ------> (192.168.1.20:82) Server

    + Configuration on Server:

    • In Bindings, I set the IP address is 192.168.1.20, Port is 82, Hostname is blank.
    • + On Firewall, I have configured NAT policy to forward port 82 on external interface to local server (192.168.1.20:82).
    • When I use the browser to access portal from internet: http://1.1.1.1:82, it show the login page, but it is still loading after enter user & pass. Accessing form internal with local IP is OK without any issue.

    Have anyone help me to troubleshoot this issue?

     Best regards,

  • Re: Can't access website with external IP IIS 8.0

    Jul 04, 2019 03:23 AM|lextm|LINK

    Use a tool like Fiddler to analyze the HTTP requests/responses in both setup. It is very likely that your login page does not behave correctly.

    Lex Li
    https://lextudio.com
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Can't access website with external IP IIS 8.0

    Jul 04, 2019 03:31 AM|DNK85|LINK

    Hello Lextm,

    If I config hostname in Bindings tab, and access from external with hostname, it is successful. But If I leave hostname blank and access from external with public IP, it can't.

    Best regards,