App Pool Hangs, Only Fixed By Restarting It.RSS

1 reply

Last post May 06, 2019 01:10 PM by lextm

  • App Pool Hangs, Only Fixed By Restarting It.

    May 06, 2019 09:42 AM|Rayce|LINK

    I am new to managing IIS.

    One of our web services is run by it's own Application Pool.

    It takes the requests, runs a SQL query, and returns some JSON.
    Roughly once to twice a month the service will seemingly freeze, and stop responding to requests.

    IIS reports the app pool as running, and no log that I know of reports an error.
    Restarting the app pool solves the problem, until it decides to hang again.

    I have tested requests to the service that I logged as occurring shortly before I believe the  app pool froze, but have been unable to duplicate the problem purposefully.

    Per some colleague's advice, as they have a similar problem, I have started a task that regularly restarts the app pool.

    Is there a way to tell exactly what request - if that is indeed the cause - is causing the app pool to hang?

    Are there any causes that might be easy to test for?

  • Re: App Pool Hangs, Only Fixed By Restarting It.

    May 06, 2019 01:10 PM|lextm|LINK

    Learn to use a performance profiler to see what's up, or open a support case to consult Microsoft support via http://support.microsoft.com. I don't assume everyone knows how to collect hang dumps and analyze on their own.

    Lex Li
    IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.