Cannot Reach Site from Device on NetworkRSS

4 replies

Last post Feb 24, 2019 11:19 PM by mbanavige

  • Cannot Reach Site from Device on Network

    Jan 11, 2019 12:50 AM|jaaywags|LINK

    Hello everyone,

    Setup: I have a site on my Microsoft 2012 R2 server that is running IIS

    Issue: I can access the site from the servers browser by typing in "site.com" and the ip, 192.168.10.5. I cannot access the site from another device on the network. View IP or site.com.

    What I Have Tried:

    I am having some trouble getting a brand new Microsoft 2012 R2 Server up and running. I have installed IIS and DNS. I created a new site and added the following bindings:

    Type     Ip                         Port     Host Name

    http     All Unassigned     80        site.com

    http     192.168.10.5         80       site.com

    http     192.168.10.5         80

    Right now I have nothing in my hosts file. I have tried a few entries in there with no success, so for now I have removed them.

    My DNS Forward Lookup Zone is named, site.com.

    I have two A Hosts:

    Host                                 FQDN                IP

    (same as parent folder)    site.com            192.168.10.5

    www                                 www.site.com   192.168.10.5

    As far as my firewall goes, I added a new Inbound Rule named "site". It is a port rule on TCP, allowing port 80. I selected "Allow the connection" on the Actions page, and the profile applies to Domain, Private, and Public.

    I have also checked World Wide Web Services (HTTP Traffic-In) and it is enabled.

    I cannot ping the device I am testing with from the server in command prompt. I also cannot ping the server from the device I am testing with.

    Whenever I try to access the site, it just sites there loading until it timesout. I have checked the pfirewall.log and it is empty. Also the C:\inetpub\logs\LogFiles\* are not saving anything from the device I am testing with.

    Any ideas? Thanks!

  • Re: Cannot Reach Site from Device on Network

    Jan 13, 2019 05:56 AM|mahamr|LINK

    Simultaneous network traces from the server and a client while testing - after the troubleshooting you have already done, it's a good time to make sure you're even seeing packets reach the server. It's possible there's something else on the network blocking them.

  • Re: Cannot Reach Site from Device on Network

    Feb 23, 2019 11:20 AM|jonas_43|LINK

    clear your device browser history and cache,also check for bad IP address or any other issue ,close  your browser and again enter all parameters.

  • Re: Cannot Reach Site from Device on Network

    Feb 23, 2019 07:26 PM|lextm|LINK

    Run a diagnostics report and it can tell you how each bindings work,

    https://docs.jexusmanager.com/tutorials/binding-diagnostics.html 

    Lex Li
    Affordable IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Cannot Reach Site from Device on Network

    Feb 24, 2019 11:19 PM|mbanavige|LINK

    jaaywags

    I cannot ping the device I am testing with from the server in command prompt. I also cannot ping the server from the device I am testing with.

    This sounds more like a network setup issue than an IIS issue.

    You don't mention what subnet mask you are using or what the IP address of your test device is.

    If your server and test device are on different subnets with no route between them then they won't communicate.

    Was the IP address, subnet mask, and default gateway that were assigned to the new server proper/valid for your network?

    Mike Banavige