Failure To Install PHP (any x64 version 5.6 and above)RSS

1 reply

Last post Aug 02, 2018 08:00 PM by lextm

  • Failure To Install PHP (any x64 version 5.6 and above)

    Jul 21, 2018 09:57 PM|KoderMonte|LINK

    For platform Windows Server 12 R2, IIS8; I tried installing PHP 5.6, 7.0, 7.1 from WebPI 5.0 and it fails in all cases the same:

    PHP 5.3.28

    This product did not download successfully: The underlying connection was closed: An unexpected error occurred on the send.

    I guess all of the named PHP versions depend upon 5.3.28, and that version is failing to install.

    RESOLUTION:

    I enabled TLS 1.1 and 1.2 in Internet Explorer Options | Advanced

    The installation still failed for the PHP Manager, for which I installed via this installer:

    https://github.com/edgardo001/PHPManagerForIIS-Versiones/blob/master

    Hope this helps someone.

  • Re: Failure To Install PHP (any x64 version 5.6 and above)

    Aug 02, 2018 08:00 PM|lextm|LINK

    Can you try the 2.0 Beta 1 installers from http://www.phpmanager.xyz/ ? I tested IIS 7.5 and 10, but not yet cover IIS 8.5 in your case. You can let me know if it works.

    Compared to the installers from that GitHub repo, 2.0 contains more bug fixes.

    Lex Li
    Affordable IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.