IIS Worker process crash on HLS client connect on WIndows 10 w/IIS Media Services 4.1RSS

1 reply

Last post Sep 11, 2017 08:54 AM by Yuk Ding

  • IIS Worker process crash on HLS client connect on WIndows 10 w/IIS Media Services 4.1

    Sep 07, 2017 07:26 PM|BillArnette|LINK

    This only happens on WIndows 10/IIS 10/IIS Meida Services 4.1, and only one some boxes.   It works fine on Windows 7/IIS 7.5

    My application creates a publishing point using the IIS Media Services REST API and is able to start POSTing to it just fine.  The application uses the Smooth Streaming Format SDK to create the stream.

    I look in INETMGR and the publishing point is receiving data.  If I look in the archive directory the files are all being written correctly.  

    Then when I connect an HLS client such as http://video-dev.github.io/hls.js/demo/

    The worker process crashes in mpeg2tssink.dll 

    The strange part is that if I start my application again (which re-creates the publishing point and starts streaming to it) the next connect attempt succeeds.

    But if I restart IIS and start over again, it again crashes on the first connect from the HLS client.  Again, restart the application and the next connection attempt succeeds.

    Dump file here: https://s3.amazonaws.com/StarWitnessSoftware/w3wp.dmp

    Again, this works perfectly fine on Windows 7/IIS 7.5/5/IIS Media Services 4.1

    I have set the correct (AFAICT) permissions on the archive directory as per another thread on this forum.

    Any thoughts?

    Thanks,
    Bill

  • Re: IIS Worker process crash on HLS client connect on WIndows 10 w/IIS Media Services 4.1

    Sep 11, 2017 08:54 AM|Yuk Ding|LINK

    Hi BillArnette,

    It looks like a bug, If there is no permission issue. If you have configured the smooth streaming correctly. Maybe you could only restore the previous version.

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.