Enable 32-bit applications in IIS RSS

1 reply

Last post Jun 21, 2017 07:18 AM by Yuk Ding

  • Enable 32-bit applications in IIS

    Jun 20, 2017 07:46 PM|luciorp|LINK

    Hi All ,

    when i set Enable 32-bit applications true on specific pool, i obtain HTTP Error 503. The service is unavailable. The test site have only a simple page html 

    On the iis is installed EXCHANGE ( IIS - Exchange Back End )

    Log Event

    • error 5002 Application pool 'Gest' is being automatically disabled due to a series of failures in the process(es) serving that application pool.
    • error 5139 A listener channel for protocol 'http' in worker process '66984' serving application pool 'Gest' reported a listener channel failure.  The data field contains the error number.
    • error 2282 The Module DLL 'C:\Program Files\Microsoft\Exchange Server\V15\Bin\kerbauth.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349.

    Can you help me ?

    Please advice. Thank you

    (sorry for my bad english Embarassed)

    windows server 2012 R2 standard 64 bit
    IIS 8.5.9600.16384
    .NET CLR VERSION V2.0.50727
    pipeline integrated
    identity ApplicationPoolIdentity

  • Re: Enable 32-bit applications in IIS

    Jun 21, 2017 07:18 AM|Yuk Ding|LINK

    Hi Luciorp,

    The error 5002 and 5139 could probably caused by the crash of IIS application pool. It seems that error 2282 provide the reason why application pool get crashed. So to fix these error, fix 2282 first. Please open application host in c:\windows\system32\inetsrv\config and find the element

    <add name="kerbauth" image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" >

    Modify this element to

    <add name="kerbauth" image="C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll" preCondition="bitness64" />

    If any other dll like owaauth.dll is reporting the same error add preCondition="bitness64" as well:

    <filter name="Exchange OWA Cookie Authentication ISAPI Filter" path="C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa\auth\owaauth.dll" enabled="true" preCondition="bitness64" />

    To fix 5139, you could try this:

    http://www.grishbi.com/2015/02/iis-application-pool-keeps-crashing/

    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.