We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >


2 replies

Last post Apr 05, 2017 08:54 PM by tylersyme


    Mar 31, 2017 04:10 PM|tylersyme|LINK

    Hello all,

    I am currently trying to use the dbDacFx provider to deploy a dacpac to a remote sequel server. However, when I do this, I get an ERROR_SCRIPTDOM_NEEDED_FOR_SQL_PROVIDER. I am doing this via command prompt.

    This error, thankfully, gave me a link which showed the dependencies I would have to install. So I went ahead and installed all the ones which weren't already installed and attempted to run the command again but ended up with the same error.

    I tried uninstalling web deploy and all the dependencies and then used Web Platform Installer to install web deploy. This also installed all required dependencies. No change. I did this for both my desktop and the remote server.

    This is the command I am running. I am often using msdeploy to deploy .zip packages to this server, so I know my connection is fine.

    msdeploy.exe -verb:sync -source:dbDacFx='C:\Users\tsyme\Documents\int_testing\.build\New folder\Database.dacpac' -dest:dbDacFx='Data Source=localhost;Initial Catalog=SkyWirePOS;Integrated Security=true',computername='https://ServerIpHere:8172/msdeploy.axd',username='InsertAdminHere',password='InsertPassHere',authType=Basic -allowUntrusted -enableRule:DoNotDeleteRule

    Thanks, would appreciate any feedback 


    Apr 03, 2017 06:37 AM|Yuk Ding|LINK

    Hi typlersyme,

    The error message  ERROR_SCRIPTDOM_NEEDED_FOR_SQL_PROVIDER could be fixed by running following command to register the command:

    "C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.6.2 Tools\gacutil" /i "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\SQLDB\DAC\130\Microsoft.SqlServer.TransactSql.ScriptDom.dll"

    If it doesn't work ,you could try to install SQL Server Data Tools or install some feature in web platform install:

    • Microsoft SQL Server 2012 Data-Tier Application Framework

    • SQL Server 2012 Transact-SQL ScriptDom

    • SQL Server System CLR Types 11.0

    Here is the disuccsion and the solution about your issue:


    Best Regards,

    Yuk Ding

    Yuk Ding

    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue.

    Apr 05, 2017 08:54 PM|tylersyme|LINK

    Thank you for your response.

    I was able to get past the error after using the gacutil on the .dll

    However, I had to manually place the .dll into the folder in order for this to work. Which meant searching my C drive for the correct dll and then copy pasting it into the folder. It seems that somehow installing ssdt sometimes does not place the files into the correct locations for web deploy.