Did you mean: IIS does not return to the default page of my document [Answered]RSS

9 replies

Last post Aug 09, 2016 07:15 PM by tobus

  • Did you mean: IIS does not return to the default page of my document

    Aug 05, 2016 02:42 PM|tobus|LINK

    Hello ,

    I develop an ASP.NET MVC application that works well with Visual Studio.

    But when I deploy on IIS I get this error


    I followed a recommendation from the Microsoft site that asks to activate the file explorer now I have this error


    I do not know how to continue.
    Thank you in advance for your advice and guidance.

  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 06, 2016 02:31 AM|lextm|LINK

    Run aspnet_regiis from .NET Framework 4.0 installation folder to register it on IIS please.

    Lex Li
    https://lextudio.com
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 06, 2016 04:44 AM|tobus|LINK

    Hello lextm ,

    I run aspnet_regiis from .NET Framework 4.0 with commande prompt aspnet_regiis -i good



    But I have the same problem this is capture

  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 06, 2016 09:42 AM|lextm|LINK

    Then what is your ASP.NET routing set for this MVC web site? If you didn't specify a default routing rule, ASP.NET runtime won't be able to jump to your default controller's default view. Well, that's purely the ASP.NET MVC ABCs you should learn from http://asp.net

    Lex Li
    https://lextudio.com
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 06, 2016 03:47 PM|tobus|LINK

    Hello ,
    Poir thank you for your answer.
    I configured it for the default route in the RouteConfig file here is the code

     public class RouteConfig
        {
            public static void RegisterRoutes ( RouteCollection routes )
            {
                routes.IgnoreRoute ( "{resource}.axd/{*pathInfo}" );
    
                routes.MapRoute (
                    name: "Default",
                    url: "{controller}/{action}/{id}",
                    defaults: new { controller = "Login", action = "Login", id = UrlParameter.Optional }
                );
            }
        }

    and the file is called in the Global.axa.


    And the controller contains the action Login Login.

    So I still do not understand what is going on my app works well on the IIS server to a friend.

  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 07, 2016 05:23 AM|lextm|LINK

    Lex Li
    https://lextudio.com
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 08, 2016 03:15 AM|Jean Sun|LINK

    Hi tobus,

    Have you installed the ASP.NET feature in IIS?

    1. Open Control Panel, Programs and Features, Turn Windows features on or off.
    2. Expand Internet Information Services, World Wide Web Services, and Application Development Features.

    3. Make sure that ASP.NET 4.5 is selected.

    And you can find how to host MVC application on IIS in the following link, please check if you miss some settings.

    http://www.asp.net/mvc/overview/deployment/visual-studio-web-deployment/deploying-to-iis

    Best Regards,

    Jean

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 08, 2016 07:28 AM|tobus|LINK

    Hi Jean Sun ,

    The .NET Framework 4.5 installed on my machine but the activation of application developments fonctionnlités I do not think of ASP.NET 4.5.

    I'm on Windows 7
    .

  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 09, 2016 06:47 AM|Jean Sun|LINK

    Hi tobus,

    Please check you have enabled runAllManagedModulesForAllRequests to true in your web.config.

    <system.webServer>
        <modules runAllManagedModulesForAllRequests="true" >  
        </modules>
    </system.webServer>

    Note: In ASP.NET websites, the value of runAllManagedModulesForAllRequests previously had to be set to true to support routing. However, once IIS 7 has been updated with a Service Pack, the value of runAllManagedModulesForAllRequests can be set to false or omitted when working with ASP.NET routing. For more information, see ASP.NET Routing on the MSDN website.

    Best Regards,

    Jean

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue.
    If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.
  • Re: Did you mean: IIS does not return to the default page of my document

    Aug 09, 2016 07:15 PM|tobus|LINK

    Good evening,


    Thank you Jean Sun this solved my problem.
    I also follow this link to better understand the problem.
    Again thank you for very much for your help.

    Resolved