Resin 3.1.12 and IIS6 : isapi filter does not load [Answered]RSS

1 reply

Last post Oct 22, 2013 10:17 PM by lextm

  • Resin 3.1.12 and IIS6 : isapi filter does not load

    Oct 22, 2013 08:19 AM|toregilb|LINK

    I am running on WIN2003 server, IIS6

    In the process of installing  Resin 3.1 I need to install the isap filer isapi_srun.dll

    The resin installer inserts it into the ISAPI filter list of IIS, but the filter is marked with a red arrow, indicating that it is not loaded.

    I remove the filter and try to add it manually through IIS, but the result is the same. The filter is added, but in a state "unknown".

    I restart IIS and when reopening the ISAP filter tab, the isapi_srun.dll is marked with the same red arrow.

    (Resin 3.1 has been installed and working fine on port 8080. But of course no java or .jsp files are seen when left in the IIS root directory, since the isapi filter is not loaded)

    What can be wrong?

  • Re: Resin 3.1.12 and IIS6 : isapi filter does not load

    Oct 22, 2013 10:17 PM|lextm|LINK

    Have you enabled it as a new Web service extension?

    http://technet.microsoft.com/en-us/library/cc771187.aspx

    The Resin documentation is good enough to reveal the steps you need to perform and please carefully read it through,

    http://www.caucho.com/resin-3.1/doc/install-iis.xtp

    Lex Li
    IIS Consulting Services at https://support.lextudio.com/services/consulting.html
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.