WinCache 1.3.5 release on SourceForge LockedRSS

0 replies

Last post Aug 20, 2013 03:11 PM by DropPhone

  • DropPhone DropPhone

    360 Posts

    Microsoft

    Moderator

    WinCache 1.3.5 release on SourceForge

    Aug 20, 2013 03:11 PM|DropPhone|LINK

    The IIS team has published the release version of WinCache Extension 1.3.5 for PHP 5.5.  This is the latest stable and production ready version of the extension for PHP 5.5.

    Installation using the Web Platform Installer is easiest, as it will automatically place the extension binary into proper location and will update the PHP configuration to enable the extension. Also, if you have the previous version of the extension installed, then Web PI will upgrade it. If you install any PHP 5.5 application by using Web PI, the WinCache Extension 1.3.5 for PHP will be offered as an optional component.

    If you install the extension manually, then follow the instructions at Installing/Configuring WinCache for PHP.

    Notes

    • In PHP 5.5, the Zend Opcache extension is now in the core PHP product, although the extension is not loaded by default.  To load the Zend Opcache extension, ensure the following line is included in the php.ini file:
    zend_extension=php_opcache.dll
    [opcache]
    opcache.enable=1

     

    • Since the Zend Opcache extension is now in the core PHP product, the WinCache opcode cache is disabled by default.  The opcode cache portion of WinCache is now deprecated, and will be removed in a future release of the WinCache extension.
    • There was a bug that caused an Access Violation (AV) on shutdown, when both the Zend Opcache extension and the WinCache extension were loaded, AND both extensions were enabled for CLI use.  An updated version of the Zend Opcache extension is available in PHP 5.5.2.  It is strongly recommended that customers use PHP 5.5.2 or later when using the WinCache Extension 1.3.5 for PHP 5.5. Installation of WinCache Extension 1.3.5 for PHP 5.5 using the Web Platform Installer will install PHP 5.5.2 or later.
    • The extension can only be used with non-thread-safe builds of PHP
    • The extension can only be used when IIS is configured to run PHP via FastCGI
    • The WinCache Extension 1.3.5 for PHP 5.5 can only be used with the x86 VC11 build of PHP 5.5.

    Thanks!

    The IIS team thanks all of you who have installed and tried early releases of the WinCache extension and provided us with feedback, bug reports and feature suggestions through the Windows Cache Extension for PHP Forum. Your involvement throughout the release process has been very valuable to us and really helped us make this a great release!