IIS 8 - ASPX website issue [Answered]RSS

10 replies

Last post May 21, 2013 05:44 AM by David Thornton

  • IIS 8 - ASPX website issue

    May 09, 2013 07:06 AM|David Thornton|LINK

    Hi There,

    I have setup a new Windows 2012 server with IIS 8 and am simply trying to publish an aspx website. The default page is default.aspx and this is set correctly in IIS. However I get this error when browsing to the website externally:

    <div id="header">

    Server Error

    </div> <div id="content"> <div class="content-container">

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    </div> </div>

    The webiste is www.triumphtech.co.uk

    Any help is much appreciated.

    Dave

  • Re: IIS 8 - ASPX website issue

    May 09, 2013 09:50 AM|terridonahue|LINK

    You mention browsing the website externally. This is from a machine other than the one hosting the website, right? Or are you meaning from a machine completely outside your network? Are you able to browse the site on the local machine itself without getting an error? Are you able tp browse the site from another machine within your network?

    Terri Donahue
    Microsoft MVP ASPNET/IIS

    Please 'Mark as Answer' if this post helps you.
  • Re: IIS 8 - ASPX website issue

    May 09, 2013 11:31 AM|David Thornton|LINK

    Yes this is when I try and access the website externally from another system. This server will become a web server to host a few of my customers websites. I am very familiar with the firewall side of this in terms of publishing the web server externally so I am confident this is setup correctly. 

    I get the same error when I access the site locally on the server.

    Thanks for the quick responce.

    Dave

  • Re: IIS 8 - ASPX website issue

    May 10, 2013 10:25 PM|terridonahue|LINK

    Since you get the same error browsing the site locally, you know it isn't firewall rules. Did you enable ASP.Net within the Windows features on your server? If not, this will not work. Open Server Manager, and click Roles. You will see Web Server listed. Click on that. You can then add features from there. Make sure that Asp.Net 3.5 and 4.0 are installed. After doing that, your site should load as expected.

    Terri Donahue
    Microsoft MVP ASPNET/IIS

    Please 'Mark as Answer' if this post helps you.
  • Re: IIS 8 - ASPX website issue

    May 11, 2013 08:50 AM|sgroenen|LINK

    I got the same problem

    In IIS 7.5 I get no problem it upgrade to 8 and now no website available anymore.Also my server will run as webserver for clients and my own business.

    Also team foundation server will not work, can't get that page active

    both ASP 3.5 and 4.5 are installed

    Stefan Groenen
    Hamont, Belgium
    www.stefagro.be
  • Re: IIS 8 - ASPX website issue

    May 14, 2013 04:21 AM|dyyo|LINK

    I went to your site and I can see the fact that it is working.

    Have you actually resolved the issue?

    Thanks 

    Regards,
    Dyyo
  • Re: IIS 8 - ASPX website issue

    May 14, 2013 04:35 AM|David Thornton|LINK

    Hi There,

    I have had to point the external record back to my original server, so I am only doing internal testing now. I am still having an issue now I have installed the ASP role, the error I am now getting is this:


    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Detailed Error Information:

    Module

    DefaultDocumentModule

    Notification
    ExecuteRequestHandler

    Handler
    StaticFile

    Error Code
    0x800700b7

    Config Error
    Cannot add duplicate collection entry of type 'add' with unique key attribute 'value' set to 'default.aspx'

    Config File
    \\?\W:\wwwroot\triumphtech.co.uk\web.config

    Requested URL

    http://www.triumphtech.co.uk:80/

    Physical Path
    W:\wwwroot\triumphtech.co.uk

    Logon Method
    Anonymous

    Logon User
    Anonymous

    Config Source:

    5: <files>
    6: <add value="default.aspx" />
    7: </files>

    More Information:

    This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.
    View more information »

  • Re: IIS 8 - ASPX website issue

    May 15, 2013 02:20 AM|dyyo|LINK

    hi david,

    the issue is pertaining the ASP.NET setup on your server. Have you made sure you install the correct .NET version and have you made sure that your site operates on the correct .NET version? You can check it from your IIS -> Application Pool

     

    Regards,
    Dyyo
  • Re: IIS 8 - ASPX website issue

    May 16, 2013 09:28 AM|terridonahue|LINK

    Try removing that portion of code (the default document settings) from your web.config file. Sounds like it is inheriting from the applicationhost.config and is causing the error. Once you remove it, the site should load as expected.

    Terri Donahue
    Microsoft MVP ASPNET/IIS

    Please 'Mark as Answer' if this post helps you.
  • Re: IIS 8 - ASPX website issue

    May 20, 2013 06:19 AM|David Thornton|LINK

    Hi There,

    I have tried this and it now works internally. I will update external DNS tonight and see what happens, I will let you know.

    Thanks again
    Dave

  • Re: IIS 8 - ASPX website issue

    May 21, 2013 05:44 AM|David Thornton|LINK

    Thansk for the help Terri, this fix worked for me.


    Dave