Error when accessing wordpress applicationRSS

3 replies

Last post Jun 11, 2013 02:41 AM by kctt

  • Error when accessing wordpress application

    Apr 24, 2013 02:32 AM|Vodyanoi|LINK

    We get the following message when accessing a wordpress application via IIS

    filename:

    \\?\C:\Windows\system32\inetsrv\config\applicationhost.config

    Line Number: 1956

    Error: Cannot add a duplicate collection entry of type 'add' with unique key attribute 'name' set tpo 'PHP53_via_FastCGI'

    When checking the listed file we can see it has only 1932 lines.

    How do we resolve this?

    Wordpress, PHP and mysql were all installed using the Webmatrix installer.

    We have carried out this installation on a number of servers and had no issues whatsoever.

    I have noticed that even though the server is a webserver with IIS7.5 installed ( running on Windows server 2008R2 standard x64 ) the webmatrix installer has installed IIS express - not sure if this has any bearing on matters.

     

     

    Regards

     

     

    Spencer

     

  • Re: Error when accessing wordpress application

    Apr 24, 2013 08:30 AM|fredcumbee|LINK

    Try adding the handler PHP53_via_FastCGI to IIS to see if that resolves the problem per the link below.

    http://forums.iis.net/t/1000207.aspx/1

    Fred Cumbee

    Please 'Mark as Answer' if this post helps you.

    OrcsWeb: Managed Windows Hosting Solutions
    "Remarkable Service. Remarkable Support."
  • Re: Error when accessing wordpress application

    Apr 24, 2013 08:38 AM|Vodyanoi|LINK

    We already have a handler for PHP53_via_FastCGI in IIS.  We have checked the settings for the handler against one of our working servers and they are identical as far as we can tell.

  • Re: Error when accessing wordpress application

    Jun 11, 2013 02:41 AM|kctt|LINK

    Check handler mappings in IIS manager and make sure you do not have same entry for PHP in web.config file in website home folder.