getting HTTP error 404 for no reason [Answered]RSS

9 replies

Last post Jan 31, 2013 06:56 AM by Rick Barber

  • getting HTTP error 404 for no reason

    Jan 28, 2013 11:32 PM|gib99|LINK

    Please go to http://www.mm-theory.com and observe the HTTP Error 404.

    This website is a webapp (with a master page) programmed in Visual Studios Express 2012 for Web. It was targeted for Framework 4.0 and Published with the File System method. I then manually uploaded it to my Windows Server 2003 machine running IIS 6.0.

    For some reason, it thinks the default page is not there, but it is.

    Under documents, I have Default.htm and nuts_and_bolts.aspx at the top of the list, and both files exist in the wwwroot directory. The App pool is MMTheoryAppPool (which I've tried restarting) with MMTheoryApp as the main app for my website. I copied it from the default app. Under the ASP.NET tab, I have the ASP.NET version set to 4.0.30319.

    The web.config file looks like this:

    [code]

    <?xml version="1.0"?>

       <configuration> 

          <system.web>

            <customErrors mode="Off"/>

            <compilation targetFramework="4.0"/>   

            <httpRuntime/> 

         </system.web>

    </configuration>

    [/code]

    I've googled this problem and the solution is always to allow the target ASP.NET version in the Web Server Extensions, but it's already allowed on my machine. I've also come across enabling directory browsing but that's on as well.

    Can anyone tell me what's going on?

  • Re: getting HTTP error 404 for no reason

    Jan 29, 2013 03:50 AM|fab777|LINK

    Hi,

    gib99

    Please go to http://www.mm-theory.com and observe the HTTP Error 404
    Observed it.

    I think the problem is (at least) a DNS issue

    c:\dig>dig www.mm-thory.com
    
    ; <<>> DiG 9.3.2 <<>> www.mm-thory.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 1205
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.mm-thory.com.              IN      A
    
    ;; AUTHORITY SECTION:
    com.                    649     IN      SOA     a.gtld-servers.net. nstld.verisign-grs.com. 1359449029 1800 900 604800 8
    6400

    You've got no DNS record for www.mm-thory.com

    That will be the first thing to have to be able to access the website.



    This message is provided "AS IS" with no warranties... But you can still mark it as answer if it's helped you.
    Fabrice ZERROUKI
    Wanna chill out? Here: JAHSound.net
  • Re: getting HTTP error 404 for no reason

    Jan 29, 2013 09:55 AM|Rick Barber|LINK

    I see the first bit of confusion in that you typed www.mm-theory.com but the link appears to be a typo at www.mm-thory.com.  If I type www.mm-theory.com in my browser, I see the behavior you described.  Putting in default.html manually redirects me to nuts_and_bolts.aspx.

    What is the line in your web logs when you hit the page and get the 404?

    Rick Barber

    OrcsWeb: Managed Windows Hosting Solutions
    "Remarkable Service. Remarkable Support."
    IIS Community Newsletter
  • Rovastar Rovastar

    5486 Posts

    MVP

    Moderator

    Re: getting HTTP error 404 for no reason

    Jan 29, 2013 11:55 AM|Rovastar|LINK

    Even more confusion.

    default.html doesn't exist

    it is

    default.htm

    that redirects to nuts_and_bolts.aspx

    Now the simplest solution here is just to add

    nuts_and_bolts.aspx

    to the top of the default docs list. It will go through them in order.

    http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/dc6eb1b4-9028-4308-9935-52b64edfad36.mspx?mfr=true

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: getting HTTP error 404 for no reason

    Jan 29, 2013 12:01 PM|Rick Barber|LINK

    Good catch, Rovastar.   Default.html was a typo on my part, I meant to type default.htm. 

    Any way, the www logs will show the sub status code if you have it enabled for logging.  Using this reference, you may be able to find out more information as to why a 404 is being generated based on that.

    http://support.microsoft.com/kb/318380

    That will enable you to better troubleshoot why default.htm is not working in IIS 6 when you have it listed as a default doc because HTML pages appear to be loading properly on your site.

    Rick Barber

    OrcsWeb: Managed Windows Hosting Solutions
    "Remarkable Service. Remarkable Support."
    IIS Community Newsletter
  • Re: getting HTTP error 404 for no reason

    Jan 29, 2013 09:47 PM|gib99|LINK

    Thanks everyone for your suggestions.

    [quote=fab777]You've got no DNS record for www.mm-thory.com



    There shouldn't be any "mm-thory" anywhere. Where did you find that? How can I correct it?

    [quote=Rick Barber]What is the line in your web logs when you hit the page and get the 404?



    This is the last line in the log after trying to visit the site:

    2013-01-30 02:08:48 192.168.1.100 GET /pdt.htm mods 80 - 66.249.73.98 Mozilla/5.0+(compatible;+Googlebot/2.1;++http://www.google.com/bot.html) 404 0 2

    I don't know what it means (or why it says 2:08--it's 7:23 PM here), but the error code seems to be 404 0 2.

    The site that you linked me to says: "404.2 - Web service extension lockdown policy prevents this request."

    All my web service extensions are set to "allowed" though.

    Come to think of it, I used to have a file called pdt.htm in the mm-theory.com website which I would sometimes reference as "pdt.htm?mods" (it's the "GET /pdt.htm mods" portion of the line above that made me think of this). If this is what it is, why would it still be referencing this file, and how would I correct it?

  • Re: getting HTTP error 404 for no reason

    Jan 30, 2013 04:16 AM|fab777|LINK

    gib99

    There shouldn't be any "mm-thory" anywhere. Where did you find that? How can I correct it?
    In your first post. And now I know that was a typo : the displayed link is actually 'http://www.mm-theory.com' but when you click on it, you're redirected to 'http://www.mm-thory.com' and that's what I did...

    This message is provided "AS IS" with no warranties... But you can still mark it as answer if it's helped you.
    Fabrice ZERROUKI
    Wanna chill out? Here: JAHSound.net
  • Re: getting HTTP error 404 for no reason

    Jan 30, 2013 10:54 AM|Rick Barber|LINK

    The substatus is actually the number right after 404 so your error code is 404.0, which is file not found.  With that being said, I found a post that you might find helpful and it looks like it has a good chance of fixing your issue:

    http://www.bryansgeekspeak.com/2011/04/iis-60-default-document-not-working.html

    Rick Barber

    OrcsWeb: Managed Windows Hosting Solutions
    "Remarkable Service. Remarkable Support."
    IIS Community Newsletter
  • Re: getting HTTP error 404 for no reason

    Jan 30, 2013 08:55 PM|gib99|LINK

    Nice! That did the trick. Thanks Rick.

  • Re: getting HTTP error 404 for no reason

    Jan 31, 2013 06:56 AM|Rick Barber|LINK

    You are most certainly welcome, gib99.  I'm glad that your issue is resolved. 

    Rick Barber

    OrcsWeb: Managed Windows Hosting Solutions
    "Remarkable Service. Remarkable Support."
    IIS Community Newsletter