We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Window Authentication in IIS7 with Internet ExplorerRSS

13 replies

Last post Jul 25, 2011 08:12 PM by chinkang

  • Window Authentication in IIS7 with Internet Explorer

    Jul 20, 2011 06:40 AM|chinkang|LINK

    Hi all, I have been looking for solution on internet for days, and I'm desperate for the solution, please kindly help me. I have an web application, published as 32-bit application, running on IIS7 on Windows 2008 SP2 -64 bit (running as Intranet app) I set the authentication method: Anonymous - Disable, Windows Authentication - Enable My problem is: I got a prompt/pop up for credential on the Internet Explorer (version 8) when access to the web page, it continue to pop up even I had inserted the correct username/password. Then i UNCHECK one of the setting in the Internet Option > Advance > "Enable Integrated Windows Authentication", after uncheck and restart IE, the web page successfully accessed. I had included the in my web.config, and I retrieve the current log in user with Context.User.Identity.Name and Page.User.Identity.Name Please help me with the setting on IIS7 so that i DO NOT need to ask my users to change their IE settings. Thank you very much!!
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 20, 2011 06:55 AM|pawan.puthran|LINK

    When you enable Windows Integrated Authentication, it can use either Negotiate (Kerberos) or NTLM. Now when you say it works, if you uncheck "Eanble Integrated Windows Authentication", then you are forcing IE to use NTLM authenticaton. You can try this from the server side in order to avoid all the users from making the above change on IE. Remove "Negotiate" under WIndows Authentication | Providers. If you need kerberos, then you have to follow certain steps in order to configure it correctly.
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 20, 2011 07:01 AM|chinkang|LINK

    I had tried to remove the "Negotiate" in the providers list and left "NTML" alone there. But the problem still persist. (fyi: I do not need the kerberos authentication) Thanks for you idea, hopefully there is other possible solution for this?
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 20, 2011 07:04 AM|chinkang|LINK

    For information, I had set the same setting in all level although I know it is not necessary.. the all level i meant here is from "Home" > "Default Web Site" > ""
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 20, 2011 08:26 AM|pawan.puthran|LINK

    Also try this.

    IE | Tools |Internet Options | Security| Local Intranet| Sites| Add the URL for your website.

     Also under Local Intranet | Custom Level | Scroll all the way to the bottom and ensure User Authentication Logon is either Automatic Logon only in Intranet Zone or with current user name and password.

  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 20, 2011 08:35 AM|chinkang|LINK

    Hi Pawan, the setting was already exist. I had tried with both settings, restart browser and clear cache, and it is still the same. By the way, I think it is more to the IIS setting. The same set of web app when operate in IIS 6, no problem for it (do not need to modify the setting in IE)
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 20, 2011 09:01 AM|pawan.puthran|LINK

    Ok.. try this,

    Windows Authentication | Advanced Settings | Uncheck - Enable Kernel-mode authentication. 

  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 20, 2011 09:14 AM|chinkang|LINK

    I tried it before =( still the same problem...
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 21, 2011 11:15 AM|rwgau|LINK

     I also have the same exact issue with my sites.  Windows Authentication is working correctly with Firefox and Safari, but not IE 8or9.

  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 21, 2011 10:14 PM|chinkang|LINK

    Hi rwgau, mine not even with firefox/safari/chrome, may I know currently what kind of setting you are using?
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 23, 2011 12:09 PM|pawan.puthran|LINK

    Are you accessing the website via a load balancer or directly via server name ? Is there any other device between the client and server ?
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 25, 2011 08:27 AM|chinkang|LINK

    I accessing the website via server name and sometime directly IP address.. There is no third party between the client(browser-IE) and server
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 25, 2011 08:54 AM|HCamper|LINK

    Hello,

    A small interrupt for this thread.

    I think pictures may help  http://blogs.iis.net/nitashav/archive/2010/03/12/iis6-0-ui-vs-iis7-x-ui-series-integrated-windows-authentication.aspx

     the guide third picture for IIS 7 Server

     make note of the "Enabled" items with "Windows Authentication".

    Martin

     

     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: Window Authentication in IIS7 with Internet Explorer

    Jul 25, 2011 08:12 PM|chinkang|LINK

    Hi Martin, the setting above already configured at the first step =) however, it still doesn't works. Thanks for the information