HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid authentication headers.RSS

9 replies

Last post Aug 08, 2015 02:51 AM by sholliday

  • HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid authenti...

    Dec 16, 2008 10:44 PM|mithusur|LINK

    I am getting the below error message in my windows 2008 server when I am trying to browse the default website in the local server. Anonymous auth is disabled. Windows auth is enabled.

     

    Error Summary

    HTTP Error 401.2 - Unauthorized

    You are not authorized to view this page due to invalid authentication headers.

     

    <div class=content-container>
    Detailed Error Information <div id=details-left>
    Module IIS Web Core
    Notification AuthenticateRequest
    Handler StaticFile
    Error Code 0x80070005
    </div> <div id=details-right>
    Requested URL http://localhost:80/
    Physical Path C:\inetpub\wwwroot
    Logon Method Not yet determined
    Logon User Not yet determined
    Failed Request Tracing Log Directory C:\inetpub\logs\FailedReqLogFiles
    <div class=clear></div></div>
    </div> <div class=content-container>
    Most likely causes:
    • No authentication protocol (including anonymous) is selected in IIS.
    • Only integrated authentication is enabled, and a client browser was used that does not support integrated authentication.
    • Integrated authentication is enabled and the request was sent through a proxy that changed the authentication headers before they reach the Web server.
    • The Web server is not configured for anonymous access and a required authorization header was not received.
    • The "configuration/system.webServer/authorization" configuration section may be explicitly denying the user access.
    </div> <div class=content-container>
    Things you can try:
    • Verify the authentication setting for the resource and then try requesting the resource using that authentication method.
    • Verify that the client browser supports Integrated authentication.
    • Verify that the request is not going through a proxy when Integrated authentication is used.
    • Verify that the user is not explicitly denied access in the "configuration/system.webServer/authorization" configuration section.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.
    </div> <div class=content-container>
    Links and More Information This error occurs when the WWW-Authenticate header sent to the Web server is not supported by the server configuration. Check the authentication method for the resource, and verify which authentication method the client used. The error occurs when the authentication methods are different. To determine which type of authentication the client is using, check the authentication settings for the client.

    View more information »

    Microsoft Knowledge Base Articles:

    </div>

     

    Ther are no webproxy, IE7 is enable for local intranet connection.

  • Re: HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid auth...

    Dec 16, 2008 11:39 PM|ganeshanekar|LINK

    Can you try steps from this KB http://support.microsoft.com/kb/942043/

    Try Step 2:

    Step 2: Add the Integrated Windows authentication native module in IIS Manager

    <script type=text/javascript> loadTOCNode(3, 'resolution'); </script>
    1. Click Start, type Inetmgr in the Start Search box, and then click Inetmgr in the Programs list.
      If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
    2. In the Connections pane, expand the computer that is running IIS 7.0, expand Web Sites, and then click Default Web Site.
    3. On the Default Web Site Home page, double-click Modules.
    4. In the Actions pane, click Add Native Module.
    5. In the Add Native Module dialog box, click to select the WindowsAuthenticationModule check box, and then click OK.

    HTH.

    ~ Ganesh

    Please: Don't forget to click "Mark as Answer" on the post that helped you. That way future readers will know which post solved your issue.
  • Re: HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid auth...

    Dec 17, 2008 01:16 AM|mithusur|LINK

    There are 2 modules related to windows authentication.

    1. windowsauthentication, this is a managed module type, entry type inherited.

    2. windowsauthenticationmodule, this is a native module, entry type is inherited.

    The above modules are already in, but still getting the same error message. Any other suggestions.

  • Re: HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid auth...

    Dec 17, 2008 02:20 AM|mithusur|LINK

    When I enable the basic authentication, its prompting for username and password, if I supply the username and password then I can view the webpage, but its not working for windows authentication.

  • Re: HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid auth...

    May 09, 2009 06:35 PM|samarsalica|LINK

    Some time your IE is set to logon anoyninous in IE Security settings kindly chnage that to inherit or change it to prompt for login credential.

    Hope it helped.

     

    Thanks

    Sam

  • Re: HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid auth...

    Aug 10, 2009 04:10 PM|diegochb|LINK

    sorry to bing up this old thread, I'm having this same issue, but trying to use this solution, I don't have the option to "Add Native Module"

    I only have: "Add Managed Module" or "Configure Native Module"

    I already have listed the managed WindowsAuthentication but, I don't have WindowsAuthenticationModule on the list... how can I add it?

    Thanks!

     PS: I'm using WS2008 64bits with IIS7

  • Re: HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid auth...

    Aug 10, 2009 04:58 PM|CarlosAg|LINK

    Could you double check if Windows Authentication is installed. You can use Server Manager and see in the Web Server role and make sure the Windows Authentication feature is installed.

  • Re: HTTP Error 401.2 - Unauthorized. You are not authorized to view this page due to invalid auth...

    Aug 11, 2009 08:27 AM|diegochb|LINK

    Yes, windows authentication is installed (basic, digest, client certificate mapping, and IIS Client Certificate Mapping authorization methots are not installed)

    thanks!

  • HTTP Error 401.2 - Unauthorized

    Dec 17, 2009 06:27 AM|richard.buff@tasb.org|LINK

    Hi, All,

    I am also experiencing this issue.  I do not have Windows Auth enabled (but I don't want it because we use Forms Auth in my app).  I have anonymous, ASP.Net impersonation, and Forms Auth enabled.  The rest are disabled.

    My site was working yesterday, but I had to reboot and now I'm getting this error.

    (Sorry to resurrect a thread that's a few months old...please feel free to create a new thread of this if it's more appropriate to do so.)  :-)

    Thanks in advance!

    Rich

     

  • Re: HTTP Error 401.2 - Unauthorized

    Aug 08, 2015 02:51 AM|sholliday|LINK

    For future readers:

    http://stackoverflow.com/questions/1267071/how-to-get-windows-user-name-when-identity-impersonate-true-in-asp-net

    Enabling both "anonymous" and "windows authentication" will result in "blank" windowsidentity values.