HTTP Error 503 - Service is UnavailableRSS

18 replies

Last post Sep 23, 2010 01:53 AM by ipnotech

  • HTTP Error 503 - Service is Unavailable

    Aug 22, 2008 01:04 PM|elizabeth213|LINK

    We are running Windows Server 2008 64 bit and IIS 7.0 

    I have Enabled 32 bit applications, but the app pool fails when I try and load the app.  I received the following errors in Event Viewer in this order.

    App log - 2280 Event Error 5 times

    The Module DLL C:\Windows\System32\RPCProxy\RPCProxy.dll failed to load.  The data is the error.  This has an error of 0000007E (In Words)

    System Log - 5139 Error 5 times

    A listener channel for protocol 'http' in worker process '4040' serving application pool 'AppPool' reported a listener channel failure.  The data field contains the error number.  This has an error of 8007007E (In Words)

    Then I receive Event 5002
    Application pool 'AppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.  No Detailed Error.

     I am running a TS Gateway / Server on this same server, but even if I stop these services I still receive all of the same errors in the Event Viewer.

     

  • Re: HTTP Error 503 - Service is Unavailable

    Aug 22, 2008 01:25 PM|anilr|LINK

    There is a known issue currently with rpc/http (which TS gateway uses) breaking 32-bit worker processes.  A fix is in the works for the next service pack.  In the meantime, you can workaround by doing one of the following

    a) Uninstall rpc/http (and therefore TS gateway)

    b) Use all app-pools in 64-bit mode

    c) Find the entries for rpcproxy.dll in globalModules and modules in applicationhost.config and add a preCondition="bitness64" to those entries.  This should cause your 32-bit app-pools to start working.  To make rpc/http work though - you would need to either make sure that DefaultAppPool is in 64-bit mode or you move the /rpc and /rpcwithcert applications to an app-pool which is in 64-bit mode.

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: HTTP Error 503 - Service is Unavailable

    Aug 22, 2008 04:00 PM|elizabeth213|LINK

     

    Thank you, we added this to the globalmodules and it worked as expected!!
  • Re: HTTP Error 503 - Service is Unavailable

    Sep 07, 2008 08:39 PM|jeltz|LINK

    I have the same configuration 9server 2008 x64 IIS 7 and receive the same error numbers, but I have no references to rpcproxy in any of the config files though.

    This problem happens even if I create a default web site with no content.

    Are there any other modules I should be looking for?

    A listener channel for protocol 'http' in worker process '4996' serving application pool '192.168.1.1' reported a listener channel failure. The data field contains the error number.

    Binary data:

    In Words

    0000: 8007007E

    <div class=e> <div class=c style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"></div> <div> <div class=e> <div class=c style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">- <System></div> <div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" /> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <EventID Qualifiers="32768">5139</EventID> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Version>0</Version> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Level>3</Level> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Task>0</Task> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Opcode>0</Opcode> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Keywords>0x80000000000000</Keywords> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <TimeCreated SystemTime="2008-09-08T00:30:01.000Z" /> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <EventRecordID>22696</EventRecordID> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Correlation /> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Execution ProcessID="0" ThreadID="0" /> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Channel>System</Channel> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Computer>Galadriel</Computer> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Security /> </div></div> <div>  </System></div></div></div> <div class=e> <div class=c style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">- <EventData></div> <div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Data Name="AppPoolID">192.168.1.1</Data> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Data Name="ProcessID">4996</Data> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Data Name="param3">0</Data> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Data Name="ProtocolID">http</Data> </div></div> <div class=e> <div style="MARGIN-LEFT: 1em; TEXT-INDENT: -2em">  <Binary>7E000780</Binary> </div></div> <div>  </EventData></div></div></div> <div>  </Event></div></div></div>

    Regards, Jeltz

  • Re: HTTP Error 503 - Service is Unavailable

    Sep 08, 2008 12:32 AM|jeltz|LINK

    Ok I reinstalled bare minimum IIs 7 + ASP.NET and windows authentication. It works Ok again. I have not yet discovered which  modeule fails to 503 response but dare say I will in time.

     

  • Re: HTTP Error 503 - Service is Unavailable

    Oct 26, 2009 08:47 PM|micnet|LINK

     I chose option C. However, after editing the goblal modules, this is the error I'm receiving:

    HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid.

     

    Detailed Error Information<div id="details-left">
    Module DynamicCompressionModule
    Notification SendResponse
    Handler ISAPI-dll
    Error Code 0x8007007e
    </div> <div id="details-right">
    Requested URL http://psesvr01:8532/fpadmdll.dll
    Physical Path C:\Program Files (x86)\Common Files\Microsoft Shared\Web Server Extensions\50\isapi\_vti_adm\fpadmdll.dll
    Logon Method Not yet determined
    Logon User Not yet determined
    </div>

      So now I'm stumped. What now?

     

     

     

  • Re: HTTP Error 503 - Service is Unavailable

    Oct 27, 2009 01:57 PM|anilr|LINK

    This means that either fpadmdll.dll or one its dependency dlls could not be found - use depends.exe on the server to figure out what is missing.

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: HTTP Error 503 - Service is Unavailable

    Oct 28, 2009 03:18 PM|micnet|LINK

    Ok, so here is the result: 

    LINKINFO.DLL- missing

    Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
    Error: Modules with different CPU types were found.
    Warning: At least one delay-load dependency module was not found.
    Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

     

    Other than the missing dll, I have no idea what the other messages mean.

    Michael

  • Re: HTTP Error 503 - Service is Unavailable

    Oct 29, 2009 07:59 PM|anilr|LINK

    I don't think linkinfo.dll is your problem - the "Modules with different CPU types were found" seems to indicate that you ran the wrong version of depends.exe - you need to run the 32-bit depends.exe for a 32-bit binary (even on a 64-bit OS).

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: HTTP Error 503 - Service is Unavailable

    Oct 30, 2009 02:17 PM|micnet|LINK

    Well, I ran the 32 bit version and received this error:

    GPSVC.DLL
    Warning: At least one delay-load dependency module was not found.
    Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

    So, once again, this is a huge pain. Right now, it seems I'm going to have to set up another box on my network with a copy of a server OS so I can load IIS and be able to get back to programming. This is so much fun.

  • Re: HTTP Error 503 - Service is Unavailable

    Oct 30, 2009 02:37 PM|anilr|LINK

    A error in a delay-load dependency module may not be a problem since the delay-load may not ever happen - I would suggest using process monitor to figure out which dll is not being found by IIS.

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: HTTP Error 503 - Service is Unavailable

    Oct 30, 2009 09:38 PM|micnet|LINK

    You're talking about a lot of technical mumbo jumbo that I have no interest, let alone time, to bother with. It would just be nice if it would work like it should. Welcome to the wonderful world of microsoft.

  • Re: HTTP Error 503 - Service is Unavailable

    Oct 31, 2009 01:59 AM|anilr|LINK

    Ok, thanks for letting me know so I do not waste any more time on this thread.

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: HTTP Error 503 - Service is Unavailable

    Dec 31, 2009 10:56 AM|Wreckless Eric|LINK

    Perhaps you could spare some time for me, as I read the discussion and I do have the same problem! (I dont think it's a waste of time to solve this problem.)

    After running depend(32) on my SBS2008, I found missing:
    GPSVC.DLL, IESHIMS.DLL and LINKINFO.DLL

    Warning: At least one delay-load dependency module was not found.

    Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

    I read this like the modules are just not there, I checked and indeed they are missing. Any clues on how to proceed?

  • Re: HTTP Error 503 - Service is Unavailable

    Sep 12, 2010 09:52 PM|beatinger|LINK

     

    elizabeth213

     

    Thank you, we added this to the globalmodules and it worked as expected!!

     

    Can you please let me know EXACTLY how you did this?  I cannot figure out where this "GlobalModules" file is or how to do this.

     There just isn't enough information.

     

    Thank you so much!

    Jay Eatinger

  • Re: HTTP Error 503 - Service is Unavailable

    Sep 12, 2010 09:54 PM|beatinger|LINK

     Hello Anil,

    Can you please let me know EXACTLY how this is done (OPTION C)?  I cannot figure out where this "GlobalModules" file is or how to do this.

    There just isn't enough information.  Thank you so much!

    Please reply to this posting system or to beatinger@gmail.com

    I appreciate your help so much!  This is extremely confusing and time consuming.

    Jay Eatinger

  • Re: HTTP Error 503 - Service is Unavailable

    Sep 13, 2010 03:10 AM|kctt|LINK

     Do you receive the same error related to rpcproxy.dll in Event Viewer?

    You can read more about GlobalModules at

    http://www.iis.net/ConfigReference/system.webServer/globalModules

    http://msdn.microsoft.com/en-us/library/ms693807%28VS.90%29.aspx

    Good luck troubleshooting.

  • Re: HTTP Error 503 - Service is Unavailable

    Sep 13, 2010 03:12 AM|kctt|LINK

    Do you receive the same error related to RPCProxy.dll in Event Viewer?

    You can read more about GlobalModules at

    http://www.iis.net/ConfigReference/system.webServer/globalModules

    http://msdn.microsoft.com/en-us/library/ms693807%28VS.90%29.aspx

  • Re: HTTP Error 503 - Service is Unavailable

    Sep 23, 2010 01:53 AM|ipnotech|LINK

     Hi Anil

     How are you?

     I am getting a lot of the above errors and followed all the tips you have given with the bitness=64, but I am still getting the error above.

    When I open the IIS7 manager (BTW I have Windows 2008 SBS with SP2 64 Bit) , under applications pools I have the following apps stopped even though autostart is TRUE and 32bit is FALSE under the advanced settings.

     These are the pools that fail to initialize:

    DefaulAppPool
    MSExchangeAutoDiscoveryPool
    SBS Sharepoint AppPool
    SBS WebApplications application pool
    SharePoint Central Administration V3
    WususPool

    Under my event viewer I get the following critical error messages:

    Application:

    - The start address <sts3s://remote.example.com.au:987/contentdbid={151f1233-2fa2-45c2-83c2-a1d6c5d7c55a}> cannot be crawled.
    Context: Application 'Search index file on the search server', Catalog 'Search'
    Details: An unrecognized HTTP status was received. Check that the address can be accessed using Internet Explorer.   (0x80041204)

    System:

    - Application pool 'WsusPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

    - Application pool 'SBS Sharepoint AppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

    - Application pool 'SharePoint Central Administration v3' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

    - Application pool 'SBS Web Applications application pool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

    - Application pool 'SBS Web Applications application pool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

    - Application pool 'DefaultAppPool' is being automatically disabled due to a series of failures in the process(es) serving that application pool.

     And there are more.

     I have modified the applicationhost.config file as suggested with the bitness parameter equal to 64 but nothing works.

    What can I do to fix this?

    Can I restore the defaults for the virtual directories and application pools? Do I need to re-install asp/aspnet? 

    How do I go about it?

    Please help me.

    Thanks a lot 

    Regards

    Alfred